
Experiment 1: The LabScribe Tutorial
LabScribe allows data to be accumulated, displayed 

and analyzed on a computer screen in a format similar to 
a laboratory strip chart recorder. 

Equipment Setup
1 Place the iWorx unit on the bench, close to the computer. 

2 Use the USB (or serial) cable to connect the computer to 
the USB (or serial) port on the rear panel of the iWorx unit 
(Figure 1-1 on page 1).

3 Plug the power plug into the rear of the iWorx unit and the 
transformer into the electrical outlet. Use the power switch 
to turn on the unit and confirm that the red power light is lit.

Start the Software
1 Click the Windows Start menu, move the cursor to 

Programs and then to the iWorx folder and select 
LabScribe; or click on the LabScribe icon on the Desktop

2 When the program opens, select Load Group from the 
Settings menu.   

3 When the dialog box appears, select IPLMV3.iws. Click 
Load.

4 Click on the Settings menu again and select the Tutorial 
settings file.

5 After a short time, LabScribe will appear on the computer 
screen as configured by the Tutorial settings (Figure 1-2 on 
page 2). The LabScribe software has seven windows:

• Main: Record incoming signals and perform data analysis.

• Analysis: Perform data analysis.

• ScopeView: Overlay blocks of Chart data for comparison.

• Journal: Type notes and insert recordings to create lab 
reports.

• Marks: Review annotations entered during data acquisition.

• Preview: Examine incoming signals without recording them.

• Stimulation: Change stimulus parameters from Main 
window.

The Main window is displayed when LabScribe is first 
opened (Figure 1-2 on page 2). Notice that each channel 
has its own (white) recording area, with a title area at 
the upper left corner, AutoScale and FullScale select 
buttons, and the Value of the voltage at the upper right. 
Above the Channel 1 is a Time value, the sampling 
Speed, the Display Time, the Mark button, the comment 
entry line, and the Start button.

 Figure 1-2: The LabScribe Main window

Connection
The output from a PT-104 pulse plethysmograph will 

be used as a signal source. Proceed as follows:

1 Locate the DIN connector on the end of the plethysmograph 
cable and plug it into Channel 3 (Figure 1-3 on page 2). 

2 Place the plethysmograph on the volar surface (where the 
fingerprints are located) of the distal segment of the middle 
finger, and wrap the Velcro strap around the end of the 
finger to attach the unit firmly in place.

 Figure 1-3: The connection between the plethysmograph and the iWorx/214.

Recording with LabScribe

The Signal

1 Click Start (Figure 1-2 on page 2) and record the finger 
pulse for at least 30 seconds. Check Channel 3 (Pulse). If 
the pulse goes down, Stop the recording. Use the Invert 
function in the right-click menu for Channel 3 to orient the 
image in the correct direction, and Start recording again.
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Note: If the iWorx unit and computer are not communicating 
there will be a sine wave in the first two recording windows. If 
this happens, click Stop to halt recording and restore commu-
nication between the computer and the iWorx by either 
selecting Find Hardware in the Tools menu, or selecting 
iWorx in the Preferences dialog under the Edit menu.

2 Click AutoScale in the Pulse channel (CH 3) title area and 
see the rhythmic signal almost fill the channel recording 
area.

3 Click Stop to halt recording; your record may look like 
Figure 1-2 on page 2.

4 Click and drag the red arrows at the right margin of the 
window, up and down to make the Pulse (Channel 3) 
recording window as large or as small as desired.

The Screen Time
The default value for the time for a signal to cross the 

screen is 10 seconds. This value is displayed as Display 
Time in the area above the Channel 1 title area (Figure 
1-2 on page 2). The Display Time can be changed by 
clicking the display controls in the LabScribe toolbar 
(Figure 1-4 on page 3).

 Figure 1-4: The display icons.

To demonstrate the display controls:

1 Click the left icon (big mountain) and notice that the trace 
spreads out; the Display Time is five seconds.

2 Click the right icon (small mountains) twice and see that the 
rhythmic peaks get closer; the Display Time is 20 seconds.

3 Click the left icon once to return to a 10-second display 
time.

The Sampling Rate
The default value for the number of samples taken per 

second is 200. This value is displayed as Speed above 
the Channel 1 recording window (Figure 1-2 on page 2). 
While this value is acceptable for most experiments, it 
can be changed by selecting Preferences in the Edit 
menu and adjusting the sampling rate. Such a change 
does not alter the screen display time.

Making Marks on a Record
Many experiments are divided into a series of 

exercises. It is convenient to annotate each exercise, so 
that during subsequent review of your data file it is 
possible to determine what was done at any particular 
stage. 

Entering Marks while recording: 

Marks can be entered “on-the-fly” while data are being 
recorded. Use the keyboard to type comments on the 
line next to the Mark button. Press the Mark button, or 
the Enter key on the keyboard, and a line will be placed 
on the recording and that line will be associated with the 
comment typed on the line. Try this:

1 Click Start.

2 Type “Mark#1” using the keyboard and notice that the words 
appear on the line to the right of Mark button (Figure 1-2 on 
page 2).

3 Press the Enter key on the keyboard and notice that:

• the words disappear

• a vertical line appears in the LabScribe window.

4 Type “Mark#2” and repeat step #3.

5 Repeat to enter a total of five different comments, pressing 
the Enter key after each.

6 Click Stop.

Entering marks when not recording: 

When data have been recorded, two blue vertical l ines 
or cursors overlay the screen. As you will discover later, 
these lines can be used to make measurements. 
However, if you use the keyboard to type a comment on 
the line next to the Marks button and press the Enter 
key, the comment will be entered in the lower margin at 
the left cursor. The last mark may be seen in the lower 
margin of the recording window.

Saving a LabScribe File
It is wise to save work in any computer application and 

LabScribe is no exception:

1 Click on the File menu and select Save As.

2 When the Save As panel appears, type the name of the file. 
Choose a destination on the computer in which to save the 
file (e.g. the iWorx or your class folder). Click the Save 
button to save the file (as an *.iwd file).
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Data Analysis of Your LabScribe File
Data analysis can be done in the either the Main or the 

Analysis window. Access to these windows can be 
gained either by using the Window menu or by clicking 
on the appropriate icon on the LabScribe toolbar (Figure 
1-5 on page 4).

 Figure 1-5: The Window icons in the LabScribe toolbar.

Data Analysis in the Main Window
Navigating the Main Window

There are two ways to navigate around a data fi le in 
the Main window: the scroll bar, or the Marks icon 
(pencil) on the LabScribe toolbar.

Scrolling

1 Move the cursor to the scroll bar in the lower margin of the 
Main window.

2 Click the arrows or move the slide to scroll the screen to the 
left or right. The typed marks appear in the lower margin of 
the window.

Marks

1 Pull down the Window menu and select Marks, or click the 
Marks icon in the toolbar (Figure 1-5 on page 4). Using 
either method will produce a panel with your typed 
comments, which may be edited at this stage.

2 Click on the Time for a given mark and then press the Go 
To button.

3 The panel will disappear and the relevant portion of data will 
be displayed in the center of the Main window.

4 The comments associated with a mark can be moved verti-
cally and placed anywhere on the recording by clicking on 
the comment and dragging the mouse. Comments in a 
given view can be reset to the lower margin by selecting 
Reset Marks under the View menu.

Making Measurements on the Main window

Measurements are taken using the cursors. These are 
vertical blue lines that address all channels and can be 
called using one of the cursor icons (Figure 1-6 on page 
4) in the LabScribe toolbar. 

 Figure 1-6: The cursor icons.

Using two cursors:

1 Click the 2-Cursor icon (two vertical bars). Two blue vertical 
lines appear over the recording window (Figure 1-7 on page 
5).

2 Click and drag the lines left and right to display the 
difference in:

• time between the positions of the two cursor lines. This 
difference is labeled as T2-T1 and is shown in the top left 
margin, above the title for Channel 1.

• voltage between the intersects of the two cursor lines on the 
trace. This difference is labeled as V2-V1 and is shown in the 
box on the upper right margin of each channel.

Using a single cursor:

1 Click the 1-Cursor icon (single vertical bar). A blue vertical 
line appears over the recording window. 

2 Click and drag the line to the left or right to make measure-
ments of:

• the absolute Time from the beginning of the trace, which is 
shown in the top left margin, above the title for Channel 1.

• the absolute Value of the voltage, which is displayed in the 
box on the upper right margin of each channel.

The Journal

The Journal is a window that can be used as a 
notebook. Notes can be typed into the Journal, data and 
traces can be copied and pasted into it, and the contents 
of the Journal can be printed. 

• Open the Journal either by selecting it from the Window 
menu or by clicking the Journal icon (clipboard) on the 
LabScribe toolbar (Figure 1-5 on page 4). 

• To transfer a recording to the Journal, use the Copy 
command in Edit menu to select the screen displayed in the 
Main window. Open the Journal window and use the Paste 
command in Edit menu to transfer the trace to the Journal.

• Return to any of the other windows by selecting that window 
from the Window menu or by clicking that window’s icon in the 
LabScribe toolbar.
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Data Analysis in the Analysis Window
Additional data analysis features are available through 

the Analysis window (Figure 1-8 on page 5). Before the 
Analysis window can be opened, a section of data in the 
Main window must be selected (Figure 1-7 on page 5). 
To select the data to be displayed in the Analysis 
window:

1 Click the 2-Cursor icon (Figure 1-6 on page 4). Two blue 
vertical lines appear over the recording window.

2 Drag the cursors left and right so that the section of the 
recording to be used in the Analysis window occurs 
between the two cursors. Place the cursors so that 2 
complete pulse cycles are selected.

3 Open the Analysis window by either selecting Analysis from 
the Window menu, or clicking the Analysis icon on the 
LabScribe toolbar (Figure 1-5 on page 4).

 Figure 1-7: Cursors placed around the section of pulse recording selected for 
use in the Analysis window.

Channel Display in the Analysis Window

In this window, the recordings from all available 
channels are displayed under one another. 

 Figure 1-8: A finger pulse recording in the Analysis window.

1 To display only one channel, click on the channel name in 
the Display Channels control box on the left margin of the 
Analysis window. Click on Pulse to display only the finger 
pulse record.

2 To select additional channels, hold down the Ctrl key as 
another channel is selected from the list in the Display 
Channels control box. Use the Shift key to select a block of 
channels.

3 If two or more channels are displayed in the Analysis 
window, the traces can be stacked or superimposed over 
each other by putting a check in the Stacked box on the left 
margin of the Analysis window.

Screen display in the Analysis Window

The Display Time in the Analysis window can be 
changed in the same manner it is in the Main window. 
Clicking on the Display Time icons (mountains) will 
double or half the display time for each click (Figure 1-4 
on page 3). The trace can also be scrolled horizontally 
by using the arrows or slider on the lower margin of the 
window.

Data Values in the Analysis Window

Data functions and values for a single channel are 
displayed across the upper margin of the Analysis 
window. To see values from another channel, select that 
channel from the pull-down menu labeled Value from Ch 
in the upper left corner of the window. The accuracy of 
the values (number of decimal places) can be set by 
using the Precision pull-down menu (Figure 1-8 on page 
5). 

The functions displayed across the top of the Analysis 
window are selected from the list labeled Table 
Functions. The titles of the functions and the matching 
data can be copied into the Journal by right-clicking the 
mouse in the data display area of the Analysis window 
and selecting either the Add Titles to Journal or Add 
Data to Journal item from this right-click menu.

Sample Data Measurement

Determine the subject’s heart rate from the finger 
pulse data displayed in the Analysis window. Also, copy 
the trace displayed in the Analysis window to the 
Journal:

1 Move the cursors so each cursor is located on a peak of an 
adjacent finger pulse.

2 Select Title and T2-T1 from the Table Functions list. Select 
Pulse from the Value from Ch menu.

3 Right-click in the Analysis window and select Add Titles 
to Journal and Add Data to Journal to transfer the title of 
the channel (Pulse) and the value measured (T2-T1) to the 
Journal.
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4 Select Copy in the Edit menu. Open the Journal from the 
Window menu or the Journal icon on the toolbar (Figure 1-
5 on page 4). Select Paste in the Edit menu. The trace in 
the Analysis window will appear in the Journal.

5 Calculate the subject’s heart rate by dividing 60 (as in 60 
sec/min) by T2-T1 (secs/heart beat). T2-T1, the time 
between pulse waves, is the period of each heart beat.

6 Return to the Main window via the Window menu or Main 
window icon on the toolbar (Figure 1-5 on page 4).

Channel Features

Additional features for each channel are available from 
the right-click menu in the Main window. Some of the 
items can be programmed before data is recorded; 
others are only active after data is recorded. Some of 
the functions available include; rates, integrals, fi lters, 
units conversions, scaling, and mathematical manipula-
tions.

To demonstrate the usefulness of one of these 
functions, integrate the finger pulse signal to display the 
blood flow through the finger:

1 Place the cursor over Channel 4, right-click the mouse. 
Select Integral, and then Regular, from the right-click 
menu. By default, Pulse (Channel 3) is selected by the Set 
Raw Ch function in the right-click menu. If necessary, click 
AutoScale for Channel 4 to display the Integral of the 
pulse.

2 Click the 2-Cursor icon (Figure 1-6 on page 4). Two blue 
vertical lines appear over the Main window.

3 Drag the cursors to the left and to the right to select a 
couple of pulse cycles between the two blue lines.

4 Open the Analysis window by either selecting Analysis 
from the Window menu, or clicking the Analysis icon on 
the LabScribe toolbar (Figure 1-5 on page 4).

5 Make the following measurements from recordings 
displayed in the Analysis window (Figure 1-9 on page 6) 
using the Title, V2-V1, and T2-T1 functions listed in the 
Tables Functions menu:

• The amplitude of the Integral on the Channel 4. Select 
Channel 4 from the Value from Ch menu, and Title and V2-
V1 from the Tables Functions menu. Place the cursors on the 
trough and the peak of an integral wave.

• The period of the Integral. Select Title and T2-T1 from the 
Tables Functions menu. Place the cursors on the peaks of 
two adjacent integral waves. The value for T2-T1 is the pulse 
period, which can be used to find the heart rate.

 Figure 1-9: Finger pulse (upper trace) and its integral (lower trace) in the 
Analysis window.

In the Future
You will use functions available in the Analysis 

window to determine values for arterial blood pressure, 
pulse amplitude, relative blood flow, heart rate, lung 
volumes, nerve conduction velocity, and more.
Chapter 1: Introduction to iWorx™ and LabScribe™ 6


	Chapter 1: Introduction to iWorx™ and LabScribe™
	Experiment 1: The LabScribe Tutorial
	Equipment Setup
	Start the Software
	Connection
	Recording with LabScribe
	The Signal
	The Screen Time
	The Sampling Rate
	Making Marks on a Record
	Saving a LabScribe File

	Data Analysis of Your LabScribe File
	Data Analysis in the Main Window
	Data Analysis in the Analysis Window
	In the Future




